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Copyright © 2021 EPLAN GmbH & Co. KG 

EPLAN GmbH & Co. KG assumes no liability for either technical or printing errors, or for deficiencies 

in this technical information and cannot be held liable for damages that may result directly or indirectly 

from the delivery, performance, and use of this material. 

This document contains legally protected information that is subject to copyright, trademark law, de-

sign law and other legal provisions. All rights are protected. This document or parts of this document 

may not be copied or reproduced by any other means without the express prior consent of EPLAN 

GmbH & Co. KG. 

The software described in this document is subject to a licensing agreement and, if applicable, other 

contractual provisions. The utilization and reproduction of the software are only permitted in accord-

ance with the specifications of this license agreement and, if applicable, any further existing contractu-

al specifications. 

RITTAL® is a registered trademark of Rittal GmbH & Co. KG. 

EPLAN®, EPLAN Electric P8®, EPLAN Fluid®, EPLAN Preplanning®, EPLAN Pro Panel®, EPLAN 

Smart Wiring®, EPLAN Harness proD®, ePULSE®, eVIEW®, eBUILD, SYNGINEER and EPLAN Cogi-

neer® are registered trademarks of EPLAN GmbH & Co. KG. 

Windows 7®, Windows 8.1®, Windows 10®, Windows Server 2008 R2®, Windows Server 2012®, Win-

dows Server 2012 R2®, Microsoft Windows®, Microsoft Office®, Microsoft® Excel®, Microsoft® Access® 

and Notepad® are registered trademarks of the Microsoft Corporation (in accordance with the laws of 

the State of Washington). 

PC WORX®, CLIP PROJECT®, INTERBUS® and PROFINET® are registered trademarks of Phoenix 

Contact GmbH & Co. KG. 

AutoCAD® and AutoCAD Inventor® are registered trademarks of Autodesk, Inc. 

STEP 7®, SIMATIC® and SIMATIC HW Config® are registered trademarks of Siemens AG. 

InstallShield® is a registered trademark of InstallShield, Inc. FLEXERA SOFTWARE LLC. 

Adobe® Reader® and Adobe® Acrobat® are registered trademarks of Adobe Systems Inc. 

Intel® is a registered trademark of Intel Corporation. 

Citrix® is a registered trademark of Citrix Systems, Inc. 

TwinCAT® is a registered trademark of Beckhoff Automation GmbH. 

Unity Pro® is a registered trademark of Schneider Electric S.E. 

RSLogix 5000® and RSLogix Architect® are registered trademarks of Rockwell Automation Inc. 

All other product names and trade names are trademarks or registered trademarks of their respective 

owners. 

EPLAN uses the Open Source software 7-Zip (7z.dll), Version 16.00, Copyright © by Igor Pavlov. The 

source code of 7-Zip is subject to the GNU Lesser General Public License (LGPL). The source code of 

7-Zip and details on this license can be found on the following Web site: http://www.7-zip.org 

EPLAN uses the Open Source software Open CASCADE, Version 7.5.0, Copyright © by Open 

CASCADE S.A.S. The source code of Open CASCADE is subject to the Open CASCADE Technology 

Public License. The source code of Open CASCADE and details on this license can be found on the 

following website: http://www.opencascade.org 

EPLAN makes an import function available which uses eCl@ss. The use of the eCl@ss standard is 

subject to a license and requires registration and downloading in the download portal: 

http://www.eclassdownload.com 
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EPLAN uses the dotNetRDF © library: http://www.dotnetrdf.org, Copyright (c) 2009-2013 dotNetRDF 

Project (dotnetrdf-develop@lists.sf.net). The source code is subject to the MIT license: 

https://opensource.org/licenses/MIT 

EPLAN uses Google Chromium ©, Version 88. https://www.chromium.org, Copyright © 2015 The 

Chromium Authors. The source code is subject to the BSD license. 

EPLAN uses the Chromium Embedded Framework ©, Version 4324. 

https://bitbucket.org/chromiumembedded/cef, Copyright © 2008-2020 Marshall A. Greenblatt. Portions 

Copyright © 2006-2009 Google Inc. The source code is subject to the BSD license. 

EPLAN uses CEFSharp ©, Version 88. https://cefsharp.github.io, Copyright © The CefSharp Authors. 

The source code is subject to the BSD license. 

EPLAN uses Microsoft Unity ©, Version 4.0.1. https://github.com/unitycontainer/unity, Copyright © 

Microsoft. The source code is subject to the Apache license, Version 2.0. 

This application incorporates Open Design Alliance software pursuant to a license agreement with 

Open Design Alliance. Open Design Alliance Copyright © 2002–2020 by Open Design Alliance. All 

rights reserved. 

EPLAN uses the PDFlib library, Version 9.2.0, Copyright © by PDFlib GmbH. Copyright reserved. 

EPLAN uses the PLOP library, Version 5.3p1, Copyright © by PDFlib GmbH. All rights reserved. 

The license management portion of this Licensee Application is based upon one or more of the follow-

ing copyrights: Sentinel® RMS, © 2005 SafeNet, Inc., all rights reserved, and Sentinel® EMS, © 2009 

SafeNet, Inc., all rights reserved. Sentinel® is a registered trademark of SafeNet, Inc.  

EPLAN uses the the Open Source software QR Code generator library, Version 1.2.1. 

https://www.nayuki.io/page/qr-code-generator-library, Copyright © by Project Nayuki. The source code 

is subject to the MIT License. 

The complete license texts for the Open Source licenses mentioned above are available in the follow-

ing file: 

<Installation directory>\bin\License.txt 
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Introduction 

Dear users, 

The team at EPLAN GmbH & Co. KG is pleased to welcome you as a 
new user. 

This document describes how you can switch the EPLAN project man-
agement over to the Microsoft SQL-Server. We are carrying out this 
switch for "EPLAN Electric P8" as an example. A corresponding transi-
tion is possible for the following program variants of the EPLAN platform: 

 EPLAN CPM 

 EPLAN Education 

 EPLAN Electric P8 

 EPLAN Fluid 

 EPLAN Preplanning 

 EPLAN ProPanel 

 EPLAN Trial. 

These instructions are intended for administrators who are already famil-
iar with EPLAN and who know how to configure an SQL-Server. 

Note: 

We used the fully licensed program variant "EPLAN Electric P8" and the 
SQL-Server "Microsoft SQL-Server 2014 Express" when drawing up this 
document. If you use a different variant or have not licensed all the mod-
ules for P8 or use a different Microsoft SQL-Server version, the figures in 
this documentation may possibly go beyond the scope of functionality of 
the software you have purchased, that is, functions are also described 
which are not available to you. 
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Notes for the Reader 

Before you begin reading, please note the following symbols and styles 
used in this document: 

Warning: 

Text preceded by this symbol contains a warning; you should be abso-
lutely sure to read this warning before proceeding! 
 

Note: 

Text preceded by this symbol contains extra notes. 
 

Tip: 

Useful tips to facilitate your interaction with the program are presented 
after this image. 
 

Example: 

Examples are highlighted by this symbol. 

 User interface elements are marked in bold so they can immediately 
be located in the text. 

 Italic text provides particularly important information that you should 
definitely pay attention to. 

 Code examples, directory names and direct entries (among other 

things) are displayed in a non-proportional font. 

 Function keys, keyboard keys, and buttons within the program are 
shown in square brackets (e.g., [F1] for the "F1" function key). 

 To improve the flow of the text, we often use "menu paths" in this doc-
ument (for example, Help > Contents). In order to find a particular 
program function, the menus and options shown in a menu path must 
be selected in the sequence shown. For example, the menu path 
mentioned above calls up the EPLAN help system. 
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 The operating information provides step-by-step instructions for reach-
ing specific targets, and in many places, after the right-arrow symbol 
 you'll also find the program's reaction to your action. 

 In combination with settings or fields (e.g., check boxes) which can 
only be switched on or off, in this document we often use the term "ac-
tivate" (after which the setting is active ) and "deactivate" (after 
which the setting is inactive ). 

 In combination with settings or fields (e.g., check boxes) which can 
only be switched on or off, in this document we often use the term "ac-
tivate" (after which the setting is active ) and "deactivate" (after 
which the setting is inactive ). 
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Requirements 

You require one of the following Microsoft SQL-Server programs in order 
to switch the project management over to an SQL-Server: 

Microsoft SQL-Server 2016 / 2017 Express / Standard or Enterprise Edi-
tion. 

More information about the software requirements and approvals can be 
found on the homepage: 

https://www.eplan.help/en-
us/Infoportal/Content/htm/portal_software_approvals.htm 

 

Notes: 

 Please note that you must have installed a Microsoft SQL-Server 
2016 / 2017 in your company in order to switch the project manage-
ment. If this is not the case, contact your SQL system administrator. 

 If you use the "SQL-Server 2016 / 2017 Express" version, you must 
have installed the Management Studio Express as well in order to 
manage the databases and users. 

 For further information about the individual versions of the Microsoft 
SQL-Server operating system please refer to the Microsoft Internet 
sites. 

If you do not have administrator rights on the SQL-Server, please contact 
your SQL system administrator. You furthermore need the name of the 
server and have to be set up as a user (with the corresponding pass-
word) on the SQL-Server in order to establish a connection to the SQL-
Server. 

  

https://www.eplan.help/en-us/Infoportal/Content/htm/portal_software_approvals.htm
https://www.eplan.help/en-us/Infoportal/Content/htm/portal_software_approvals.htm
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Switching the Project Management 

Establishing the Connection to SQL-Server and 
Database 

Caution: 

In order to create a database with the EPLAN table structure on the 
SQL-Server you require administrator rights on the SQL-Server for the 
following steps. Please contact your SQL system administrator to this 
purpose. 

Open the settings dialog for the project management in order to set up 
the SQL-Server. 

1. Select Options > Settings > User > Management > Project man-
agement database. 

 The Settings: Project management database dialog is opened. 

 

2. Select the SQL-Server option and click [New]. 



Switching the EPLAN  
Project Management to SQL-Server 
EPLAN Platform Version 2.9 
Status: 05/2021 

 

10    

 

 The Generate SQL-Server database dialog is opened. 

 

3. Enter the server name and the instance name of the SQL-Server in 
the Server field. 

4. Enter a new name for your project management database in the Da-
tabase field. 

Caution: 

Do not use hyphens in the name of the SQL database. 

5. During Login, select the variant specified by your SQL administrator. 

Note: 

You have two possibilities for logging on to an SQL-Server:  
"Windows authentication" uses the logon data of your Windows user 
account. 
If "SQL-Server" is selected, you use a separate user name and 
password. 
If a user has not been set up yet for accessing the SQL-Server, 
please contact your SQL system administrator. 
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6. Confirm your settings in the Generate SQL-Server database dialog 
by clicking [OK]. 

 The new database is created. 

 

7. Click [OK] to confirm the settings. 

  



Switching the EPLAN  
Project Management to SQL-Server 
EPLAN Platform Version 2.9 
Status: 05/2021 

 

12    

Reading Projects into the SQL Database  

After you have successfully created a database on the SQL-Server, it 
does not yet contain any projects. Carry out the following steps to read 
your projects successfully into the database: 

1. Select Project > Management. 

 The Project management message is opened. 

 

2. Click [Yes] to read in the projects that are located in the set EPLAN 
project directory 

 The Project management dialog opens. 
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Reading More Directories into Project Man-
agement 

If you want to read projects from other directories into the project man-
agement, proceed as follows: 

1. Select Project > Management. 

 

 The Project management dialog opens. 
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2. Click [Extras] > Load directory. 

 

 The Select initial directory dialog is opened. 

 

3. Select the desired directory and click [OK]. 

 All the projects from the selected directory and its subdirectories 
are read into project management.  
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